In case you are using the older PrestaShop version 184.108.40.206 you may get the following error message when installing
The version of your module is not compliant with your PrestaShop version.
Unfortunately this is due to a bug in the PrestaShop core (see ) and can only be solved by upgrading to at least PrestaShop version 220.127.116.11.
This only applies to PrestaShop version 18.104.22.168. PrestaShop has already fixed this bug in version 22.214.171.124.